I have an issue with a mount point that was previously configured. It shows the folder, but the mount is missing and holds "?" values for size, permissions, etc.

So I tried to remount using cifs and the same command from before:

mount -t cifs //nas.domain.local/share /mnt/archive

But I get the error:

Host is down.

If I ping the domain or IP I get a proper resolution and I also connected using smbclient without issue

 ping nas.domain.local
 ping ip
 smbclient //nas.domain.local/share

I looked around, but cant find a solid answer. Any thoughts?

  • do a nslookup nas.domain.local does it equal the ip you pinged? – tony roth Aug 3 '12 at 17:19
  • Yes, the IP returned is accurate. I can access the web interface of the NAS using the IP and domain as well. I can access the data on my laptop using either the domain or IP so it seems there is some other issue at play here – Kevin Aug 3 '12 at 17:28
  • 6
    Add the --verbose switch to your mount command, post any errors/results that seem relevant. – Zoredache Aug 3 '12 at 17:55
  • Is the service even running on the remote server. It is a Linux or Windows Server? If it is Linux... verify that the service is running. Make sure no changes have been done to the firewall... If it is windows... then you might consider a reboot... – Jay Aug 6 '12 at 22:06
  • 1
    @Zoredache Add -vvv for even more verbose information! – Serge Stroobandt Apr 23 '15 at 17:36

14 Answers 14

This could be also because of a protocol mismatch. In 2017 Microsoft patched Windows Servers and advised to disable the SMB1 protocol.

From now on, mount.cifs might have problems with the protocol negotiation.

The error displayed is "Host is down.", but when you do debug with:

smbclient -L <server_ip> -U <username> -d 256

you will get the error:

protocol negotiation failed: NT_STATUS_CONNECTION_RESET

To overcome this use mount or smbclient with a protocol specified.

for sbmclient: add -m SMB2 (or SMB3 for the newer version of the protocol)

smbclient -L <server_ip> -U <username> -m SMB2

or for mount: add vers=2.0 (or vers=3.0 if you want to use version 3 of the protocol)

mount -t cifs //<server_ip>/<share> /mnt/<mountpoint> -o vers=2.0
  • My NAS is on Linux when I try your solution smbclient -L 192.168.1.47 -U admin -d 256 everything works perfectly but when I try mount -t cifs -o username=aa,password=bb,uid=olivier //192.168.1.47/partagefichiers/ /mnt/PartageFichiers it keeps saying mount error(112): Host is down – Olivier Pons Jan 12 at 10:51
  • 3
    Have you tried to specify protocol as I explainde in this answer? Try adding vers=2.0 or vers=3.0 or vers=1.0 (depending on this NAS settings) by adding: mount -t cifs -o username=aa,password=bb,uid=olivier,vers=2.0 //192.168.1.47/partagefichiers/ /mnt/PartageFichiers – Marcin P Jan 13 at 11:47
  • 4
    Strange. The man page says that vers=1.0 is the default, but I couldn't get my network drive to mount before I explicitly passed vers=1.0. – Hubro Feb 6 at 5:39
  • Is it possible to change that on windows side? I have a piece of software that forwards this options to cifs and it does not know the vers option so it is not forwarded. – Andrew Savinykh May 1 at 22:28

On archlinux after a recent package update, I had to add vers=1.0 to my mount options. I'm connecting to an old centos 5 box and up until yesterday I could connect without explicitly stating a version number.

  • Thanks, I had the same issue however I don't know which upgrade makes this necessary. – Ben Oct 6 '17 at 18:54
  • This is a really weird problem. Same thing happened to me today. I tried downgrading smbclient and libwbclient, but the problem persisted. Maybe something on the server changed. I think it's CentOS too, I hope not CentOS 5! Thanks for the workaround :) – jPlatte Oct 9 '17 at 11:27
  • I had to do this for my Fedora 26 system accessing a mount on my Synology NAS DS413j, my /etc/fstab now has ",vers=1.0" on the end of the options string and no more 'Host is down' error message. – Neek Nov 1 '17 at 6:41

USB-stick at Fritz NAS showed "Host Down" for Ubuntu 17.10:

Defining the version (vers=1.0) worked - here's the full string:

sudo mount -t cifs -o vers=1.0,_netdev,username=<user>,password=<pwd>,uid=1000,gid=1000  //192.168.178.1/fritz.nas <local mountpoint>
  • 2
    Everything was working from within /etc/fstab cifs mount; after apt upgrade on my Ubuntu 16.04 this happened. Specifying the -o vers=1.0 did the trick. Thank you – equivalent8 Jan 12 at 13:02

Sorry if this is a late response (I realise it's an old thread), however I have just discovered there is another possible reason why mount.cifs would say the host is down.

I have an antivirus with a firewall and even though I set it explicitly to allow "windows file and print sharing" -- a predefined rule, it was still blocking connections. I had that proven by disabling the firewall temporarily. Hope this helps someone, host is down might not mean it's not responding to pings, but could mean it's not responding to authentication attempts.

  • Remember to check the firewall in both sides: client and server (as well as any firewall that might there be in the way between them). In my case, it was the client's firewall that was blocking connections to the server. I had to add iptables rules to allow them: iptables -A INPUT -s 1.2.3.4/32 -j ACCEPT and iptables -A OUTPUT -d 1.2.3.4/32 -j ACCEPT, where 1.2.3.4 was the server's IP address. – Antonio Vinicius Menezes Medei Sep 12 '16 at 13:44
  • My NAS is on Linux so I still have this problem, but thanks for sharing – Olivier Pons Jan 12 at 10:48

I received the same error without further ado from a new Samba client, when trying to mount a CIFS SMB network share:

mount error(112): Host is down

Eventually, it turned out I had previously restricted SMB server access to only a limited number of IP addresses by configuring /etc/samba/smb.conf:

# Allow these IP Addresses to connect: 
hosts allow = 127.0.0.1 127.0.1.13 127.0.1.63

# Anything else not allowed is, by default, rejected
hosts deny = ALL

Adding the fixed IP address of the new SMB client solved the issue in this specific case.

Of course, there is a myriad of other reasons why one may receive above-mentioned error.

Similar problem after upgrade to ubuntu 17.10, with an old Buffalo Diskstation. Solved by adding in /etc/fstab the "vers=1.0" option:

//myWDhostname/partage /media/Partage cifs guest,vers=1.0 0 0

  • Anybody using Ubuntu 18.04, adding the ,vers=1.0 option solves the problem when using the tutorial provided by Ji m at ubuntuhandbook.org/index.php/2014/08/… – Geppettvs D'Constanzo May 26 at 22:04
  • I have the same problem and can solve it by using version 1 in the protocoll. But I have a very low rate of transmission of data. I suspect it might be due to version 1, so using another version would be better. – Ben Jul 9 at 18:01

Same trouble with Fritzbox 7490: mount error(112): Host is down

I didn't used -o vers=XX. As fast as a shark i am, i first tried -o vers=2.0 and failed.
As soon as i used the option -o vers=1.0, everything works fine !

This works for me..

 sudo mount -t cifs -o rw,username=myname_on_the_box,pass\word=mypasswd_on_the_box,vers=1.0 //192.168.1.1/Fritz-nas /media/something/something    

My env:
Client: Ubuntu 17.10 Linux 4.13.0-17-generic #20-Ubuntu SMP x86_64 GNU/Linux
Server: Fritzbox 7490 firmware 6.83.

  • AVM uses an outdated version of Samba that they maintain themselves. That probably explains why one has to use vers=1.0 instead of the more appropriate newer protocol versions. – 0xC0000022L Jul 30 at 21:09

Same trouble connecting to Synology DiskStation (DSM 4.3).

Using vers=1.0 in the mount options works fine.

Additionally I had to use the option "noperm" because all files wrongly showed as not readable and writable by the owner.

The SMB1 version of the protocol has been deprecated, however this is the default version used in older versions of mount.cifs, e.g. I have this problem with version 6.2.

You can check with: sudo mount.cifs --version

If you try to connect to an SMB3 server using SMB1 protocol, you get the Host is down error.

The workaround, as described by many other answers here, is to specify a different version of the protocol. The following command works for me: sudo mount -t cifs //server.name.or.ip/shares/Public /target/directory -o username=someuser,domain=somedomain,vers=3.0

However, if the server that you are connecting to uses DFS, then you will get the following error instead: mount error(38): Function not implemented. This is because DFS support on SMB3 was only added to the kernel in version 4.11.

You can check your kernel version with uname -a. In my case, it was 3.10 on CentOS7. I followed these instructions to upgrade and now it works.

I typically use this type of command to mount a cifs/smb share.

mount -t cifs -o rw,netbiosname=nasserver1,credentials=/etc/user_credentials.txt //192.168.1.11/someshare /mnt

the credentials file looks like so:

username=mydomain\user1
password=somepass

This can also be adapted to an automount setup so the mounting/unmounting can be handled by the system automatically via autofs.

In our case I checked the users login name (of user2) in the AD. There I noticed that the name was starting with an upper case letter and changed it to lower case as it is written in the mount script. Even if we did not touch neither user2 nor the mount script before, suddenly the mount command was successful.

mount --verbose -t cifs //pc/share /my-share -no user=user1,password=pw1 -o uid=user2,gid=group1,dir_mode=0775,file_mode=0664

For me, the mounted cifs share was on a Windows server whose IP address had changed recently, so I could ping the server and resolve its new address, but the mount had not updated itself. By running a lazy unmount and then re-mounting my issue was solved:

umount -l /mnt/share
mount -a

I also just ran into the problem mentioned after an upgrad to Xubuntu 17.10. I use a Synology DiskStation. What I saw there: In the DiskStation, you can choose which protocols to support. By adding he relevant protocols (up to SBM3) in the advanced options for file services in control panel, you can also solve the problem.

Had a similar problem. The solution for me was on the Windows share server side. Even passing the value vers=2.0 to my Linux server, the mount wasn't working. So I had to enable on my Windows server smbv1 support. This article helped me: https://support.microsoft.com/en-us/help/2696547/how-to-detect-enable-and-disable-smbv1-smbv2-and-smbv3-in-windows-and

  • 2
    Don't do this. smbv1 is the vector that WannaCry uses to spread and is being phased out everywhere. – Andrew Schulman Feb 2 at 2:08

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.